Archives des étiquettes : excel

Comment se servir de la fonction SI sur excel ?

La fonction SI vous permet d’effectuer des calculs en fonction d’une condition,

le résultat pouvant être une valeur numérique ou une chaîne de caractères.

Plusieurs conditions peuvent être imbriquées les unes dans les autres.

LA FONCTION SI SIMPLE

Vous utilisez la fonction logique SI lorsque vous avez besoin d’effectuer des tests sur le contenu d’une cellule.

Si le test est positif, l’expression placée après le 1er point virgule est utilisée et, dans le cas contraire, l’expression placée après le deuxième point virgule renvoie une valeur.

La syntaxe : = SI (EXP; VALEUR_SI_VRAI ; VALEUR_SI_FAUX)

Exemples  :

Voici un test simple avec un résultat sous forme de texte

=SI (D6>=2000 ; « ALERTE » ; « OK »)

Voici un test avec une formule comme résultat sinon 0

=SI (D7>1500 ; D7*2% ; 0)

Voici un test avec un condition ET

=SI (ET(C13= »F »;D13=3); »contact »; » »)

Voici un test sur une formule

=SI (ESTERR (B5/B6) = VRAI ; »interdit »;B5/B6)

=SI (ESTVIDE(B5) = VRAI ; « vide » ; B5)

UN SI A L’INTERIEUR D’UN AUTRE SI

Il est parfois nécessaire de réaliser une condition SI à l’intérieur d’une fonction SI,

c’est à dire de mettre en place une condition imbriquée.

Voici un exemple de calcul de primes :

Si D4 >50 alors on affecte une prime de 10

Si D4 >30 alors on affecte une prime de 5

Si D4 >0 alors la prime est de 0

Dans un calcul à l’intérieur d’une condition SI, ne mettez pas de signe égal (=) à l’intérieur d’une autre formule SI.

=SI (D4>50 ; 10 ; SI (D4>30 ; 5 ;0 ) )

Avec trois conditions, vous aurez 2 fonctions SI imbriquées. Attention aux parenthèses.

Avec quatre conditions, vous aurez 3 fonctions SI imbriquées.

Au-delà ; employez la fonction RECHERCHE pour gérer les conditions multiples.

 

CALCUL DE COMMISSION POUR DES COMMERCIAUX

– Pour un CA (cellule A1) supérieur ou égal à 30000, le commercial gagne 20% du CA

– Pour un CA supérieur ou égal à 15000, le commercial gagne 15% du CA

– en dessous, le commercial gagne 10% du CA

=SI(A1>=30000 ;20% * A1 ; SI(A1>=15000 ; 15% *A1 ; 10%*A1))

 

Voici trois fonctions SI imbriquées :

=SI(B8>800;350;SI(B8>500;210;SI(B8>300;120;50)))

Au delà de trois fonctions SI, il est plus raisonnable d’utiliser la fonction RECHERCHE à la place.

 

Vous recherchez une formation Excel ? rendez-vous sur notre site www.cnfce.com / formation Excel

 

organisme de formation CNFCE

Comment se servir des fonctions RECHERCHEV et SIERREUR sur excel ?

Réglementation formation gestes et postures au travail

La fonction RECHERCHEV permet de trouver une chaîne de caractère ou un nombre dans une liste puis d’en déduire une valeur placée dans une autre colonne sur la même ligne que le critère cherché.

La fonction SIERREUR() permet de tester s’il y a des erreurs

ffe.png

Dans le cas où ce dernier n’est pas trouvé, Excel renvoie une erreur et la fonction SIERREUR permet justement d’agir pour éviter d’afficher le code erreur.

L’expression  =RECHERCHEV($A7;base1!$A$1:$E$285;5;FAUX) recherche d’abord une valeur située dans la cellule A7, de la feuille Base1 dans le groupe de cellules A1:E285.

Si cette valeur est trouvée, Excel va renvoyer la valeur située dans la 5ème colonne sinon il va renvoyer une expression #N/A (non accessible).

Le paramètre FAUX indique que la recherche du critère se fait exactement sur tous les caractères.

On utilise la paramètre VRAI lorsqu’on utilise la fonction RECHERCHEV pour rechercher une valeur numérique entre deux valeurs, comme le fait la fonction RECHERCHE.

Le signe $ est employé pour éviter les erreurs de recopie de la formule.

– $A7 fixe la colonne A

– Base1!$A$1:$E$285 fixe le bloc de cellules A1:E285

L’expression =SIERREUR( RECHERCHEV ( $A7 ; base1!$A$1:$E$285 ; 4 ; FAUX ) ; «  » ) renvoie une valeur vierge si la recherche n’a pas abouti.

 

Vous recherchez une formation Excel ? rendez-vous sur notre site www.cnfce.com / formation Excel

 

organisme de formation CNFCE

Qu’est ce que la valeur cible sur Excel ?

Qu’est ce que la valeur cible sur Excel ?

Le dispositif valeur cible permet de trouver la valeur d’un paramètre servant à réaliser une formule. Une hypothèse est définie et Excel doit « remonter » le calcul.

Lire la suite

Comment utiliser les formules du tableau croisé dynamique sur Excel ?

Comment utiliser les formules du tableau croisé dynamique

Lorsqu’un tableau croisé dynamique est réalisé, il est parfois nécessaire de créer des formules à partir des résultats du tableau croisé.

Par défaut, Excel est programmé pour afficher une formule spécifique correspondant à chaque cellule du TCD.

Lire la suite

Comment faire une liste dans une cellule Excel ?

Comment faire une liste dans une cellule Excel ?

Excel permet de définir des listes déroulantes dans des cellules de manière à sécuriser la saisie des données.

Le contenu des listes se trouve dans un bloc de cellules lui-même potentiellement situé dans une feuille particulière.

Lire la suite

Comment utiliser le calcul matriciel sur Excel

Utilisation du calcul matriciel sur Excel

Un calcul matriciel sur Excel emploie des groupes de cellules plutôt que des cellules individuelles.

Avec un calcul matriciel vous effectuez des calculs sur des blocs de cellules et le résultat n’est plus modifiable, ce qui représente une sécurité puisque vous n’avez plus le droit de changer ou de supprimer le résultat.

Lire la suite

Excel : Comment utiliser une table de données à une variable

La table de données à une variable

Excel vous permet de tester différentes valeurs appliquées à une formule à partir d’une table appelée table de données ou table d’hypothèses. Ce dispositif vous évite d’écrire des formules puis de les recopier.

Lire la suite

« Entrées précédentes