Comment se servir de la fonction SI sur excel ?

La fonction SI vous permet d’effectuer des calculs en fonction d’une condition,

le résultat pouvant être une valeur numérique ou une chaîne de caractères.

Plusieurs conditions peuvent être imbriquées les unes dans les autres.

LA FONCTION SI SIMPLE

Vous utilisez la fonction logique SI lorsque vous avez besoin d’effectuer des tests sur le contenu d’une cellule.

Si le test est positif, l’expression placée après le 1er point virgule est utilisée et, dans le cas contraire, l’expression placée après le deuxième point virgule renvoie une valeur.

La syntaxe : = SI (EXP; VALEUR_SI_VRAI ; VALEUR_SI_FAUX)

Exemples  :

Voici un test simple avec un résultat sous forme de texte

=SI (D6>=2000 ; « ALERTE » ; « OK »)

Voici un test avec une formule comme résultat sinon 0

=SI (D7>1500 ; D7*2% ; 0)

Voici un test avec un condition ET

=SI (ET(C13= »F »;D13=3); »contact »; » »)

Voici un test sur une formule

=SI (ESTERR (B5/B6) = VRAI ; »interdit »;B5/B6)

=SI (ESTVIDE(B5) = VRAI ; « vide » ; B5)

UN SI A L’INTERIEUR D’UN AUTRE SI

Il est parfois nécessaire de réaliser une condition SI à l’intérieur d’une fonction SI,

c’est à dire de mettre en place une condition imbriquée.

Voici un exemple de calcul de primes :

Si D4 >50 alors on affecte une prime de 10

Si D4 >30 alors on affecte une prime de 5

Si D4 >0 alors la prime est de 0

Dans un calcul à l’intérieur d’une condition SI, ne mettez pas de signe égal (=) à l’intérieur d’une autre formule SI.

=SI (D4>50 ; 10 ; SI (D4>30 ; 5 ;0 ) )

Avec trois conditions, vous aurez 2 fonctions SI imbriquées. Attention aux parenthèses.

Avec quatre conditions, vous aurez 3 fonctions SI imbriquées.

Au-delà ; employez la fonction RECHERCHE pour gérer les conditions multiples.

 

CALCUL DE COMMISSION POUR DES COMMERCIAUX

– Pour un CA (cellule A1) supérieur ou égal à 30000, le commercial gagne 20% du CA

– Pour un CA supérieur ou égal à 15000, le commercial gagne 15% du CA

– en dessous, le commercial gagne 10% du CA

=SI(A1>=30000 ;20% * A1 ; SI(A1>=15000 ; 15% *A1 ; 10%*A1))

 

Voici trois fonctions SI imbriquées :

=SI(B8>800;350;SI(B8>500;210;SI(B8>300;120;50)))

Au delà de trois fonctions SI, il est plus raisonnable d’utiliser la fonction RECHERCHE à la place.

 

Pour aller plus loin, vous pouvez retrouver ces ouvrages qui s’adressent à toutes les personnes qui souhaitent approfondir leurs connaissances sur Excel.

a changer.png

Vous recherchez une formation Excel ? rendez-vous sur notre site www.cnfce.com / formation Excel

 

organisme de formation CNFCE

Laisser un commentaire

Entrez vos coordonnées ci-dessous ou cliquez sur une icône pour vous connecter:

Logo WordPress.com

Vous commentez à l'aide de votre compte WordPress.com. Déconnexion / Changer )

Image Twitter

Vous commentez à l'aide de votre compte Twitter. Déconnexion / Changer )

Photo Facebook

Vous commentez à l'aide de votre compte Facebook. Déconnexion / Changer )

Photo Google+

Vous commentez à l'aide de votre compte Google+. Déconnexion / Changer )

Connexion à %s